Cloudflare Outage

Incident Report for Snappt

Resolved

The Cloudflare-related disruption observed earlier today has been fully resolved. Snappt systems are functioning normally, and we’ve confirmed stability across all services. We’ll continue to keep an eye on performance, but no additional action is needed at this time.
Posted Nov 18, 2025 - 18:39 UTC

Update

Service provider issues impacting performance earlier today have been resolved, and all Snappt systems are functioning normally. Our team will continue to monitor for any fluctuations and is prepared to respond immediately if further problems arise.
Posted Nov 18, 2025 - 16:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 15:54 UTC

Investigating

Snappt is currently affected by a Cloudflare outage. Our team is monitoring the situation and investigating any impact to our platform.
Posted Nov 18, 2025 - 14:49 UTC
This incident affected: Applicant Experience, Enterprise Partner API, and Leasing Agent Experience.