Identify verification delays

Incident Report for Snappt

Postmortem

We identified that the root cause of the failure was reaching the API rate limits with our primary verification vendor. To prevent this from happening again, we’ve implemented several safeguards:

  • Improved monitoring and alerting to detect when our API usage is approaching rate limits.
  • Backoff and throttling mechanisms that automatically slow API calls to prevent exceeding those limits.
  • Automatic retry logic so that if a report does fail due to rate limiting, it will retry automatically rather than remaining unresolved.
Posted Mar 10, 2026 - 17:35 UTC

Resolved

Some identity verification responses were delayed starting on Thursday, 3/5, at about 2 PM PT. The root problem was identified shortly after and resolved on Friday 3/6 at 2 PM PT, but it took until Sunday 3/8 at about 7 AM PT for the complete backlog of delayed verifications to be processed.
Posted Mar 05, 2026 - 22:00 UTC