All delayed requests have been reprocessed as of ~11:50am PDT.
Posted Sep 02, 2026 - 19:08 UTC
Update
All VOR requests have been reprocessed.
Our ID Verification vendor declared an incident during our reprocessing. We successfully reprocessed 75% of the delayed ID verifications before the incident began. We will reprocess the rest when their incident is resolved. We do not have an ETA yet.
Posted Sep 02, 2026 - 17:41 UTC
Update
Identity Verification requests and Verification of Rent requests processed between ~7:30am and ~8:30am PDT were delayed. We are reprocessing them and they should be completed by 10am PDT.
Posted Sep 02, 2026 - 16:27 UTC
Monitoring
The API was degraded starting a 7:24 am PST. You may have experienced intermittent timeouts or dropped connections.
Posted Sep 02, 2026 - 14:54 UTC
This incident affected: Applicant Experience, Enterprise Partner API and Verification of Rent (Yardi Integration, Other Integration, Trigo Web Application).