Fraud and Income Report Processing Delays

Incident Report for Snappt

Resolved

This incident has been resolved. Turnaround time is now back to normal.
Posted Oct 15, 2025 - 02:52 UTC

Update

Turnaround times are now back in normal ranges! We will continue monitoring for the next couple of hours to ensure this is fully resolved. Thank you for your patience.
Posted Oct 14, 2025 - 23:03 UTC

Update

We are continuing to make progress on improving our turnaround time. All submissions are currently within a 2 hour turnaround time and we are seeing steady improvement.
Posted Oct 14, 2025 - 20:51 UTC

Monitoring

We are experiencing slower processing times for income and fraud verification reports, resulting in some submissions with a turnaround delay of up to approximately 3–8 hours. The issue stemmed from a code change that prevented some submissions from being routed for review, creating a backlog. The fix has been implemented, and backlogs are being cleared. We expect turnaround times to return to normal by end of day.
Posted Oct 14, 2025 - 19:35 UTC

Investigating

We are experiencing slower processing times for income and fraud verification reports, resulting in some submissions with a turnaround delay of up to approximately 3–8 hours. The issue stemmed from a code change that prevented some submissions from being routed for review, creating a backlog. The fix has been implemented, and backlogs are being cleared. We expect turnaround times to return to normal by end of day.
Posted Oct 14, 2025 - 19:35 UTC
This incident affected: Enterprise Partner API and Leasing Agent Experience.