Identity Verification is unavailable for some applicants

Incident Report for Snappt

Resolved

This incident has been resolved.
Posted Aug 12, 2026 - 00:08 UTC

Monitoring

Our Identity Verification partner has resolved the issue on their side and systems appear to be operating normally. We will continue to monitor.
Posted Aug 11, 2026 - 23:47 UTC

Update

We're in direct communication with the affected Identity Verification Partner. They're investigating the problem from their side to why we're unable to connect. Expect another update in approximately 30 minutes.
Posted Aug 11, 2026 - 23:20 UTC

Identified

Applicants attempting to verify their identity outside the US or who, for whatever reason, cannot use CLEAR to verify their identity, are experiencing widespread errors. We've identified the issue and are working on a resolution.
Posted Aug 11, 2026 - 22:59 UTC
This incident affected: Applicant Experience.