Identity Verification

Incident Report for Snappt

Resolved

This incident has been resolved. The identification inbox and associated reports should now be behaving as expected.
Posted Mar 20, 2026 - 14:53 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2026 - 14:17 UTC

Investigating

Snappt has discovered In certain circumstance the Verification Inbox is failing to load the Identification reports. We've also been notified of slow load times for the identity report themselves. The cause of these issues has been found, and a fix is currently being tested before it is deployed to production.
Posted Mar 19, 2026 - 20:45 UTC
This incident affected: Leasing Agent Experience.