Income Verification Results Delayed

Incident Report for Snappt

Resolved

All delayed IV Results have been successfully processed, and all systems are operating normally.
Posted Apr 18, 2026 - 04:38 UTC

Monitoring

We've verified that the problem has been remediated. We're still working to make sure delayed submissions are within SLA.
Posted Apr 18, 2026 - 04:04 UTC

Identified

We've identified the probable cause of the issue and are working on a fix.
Posted Apr 18, 2026 - 03:13 UTC

Investigating

We've discovered a large backlog of Income Verification Results awaiting finalization. We're currently investigating the root cause of the issue.
Posted Apr 18, 2026 - 02:59 UTC
This incident affected: Leasing Agent Experience.