CLEAR Identity Verification Outage

Incident Report for Snappt

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 18:13 UTC

Investigating

We have been notified by CLEAR , our Identity Verification provider that they are experiencing a system wide outage. They have opened an incident on their side and are actively investigating the issue. We have no estimated resolution timeline yet.
Posted Sep 02, 2026 - 17:47 UTC
This incident affected: Applicant Experience.