Income Calculation Investigation

Incident Report for Snappt

Resolved

This incident has been resolved.
Posted Oct 18, 2025 - 01:22 UTC

Investigating

Investigating a possible issue with income calculation on a portion of submissions
Posted Oct 18, 2025 - 00:07 UTC
This incident affected: Leasing Agent Experience.