Service Disruption Across Core Platform

Incident Report for Snappt

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 16:48 UTC

Identified

We are currently experiencing a service disruption impacting parts of our fraud platform and the applicant experience. Some users may encounter errors, delays, or limited functionality.

Our team has identified the issue and is actively working to restore full service as quickly as possible. We will continue to provide updates as progress is made.

We apologize for the inconvenience and appreciate your patience.
Posted Mar 03, 2026 - 16:30 UTC
This incident affected: Applicant Experience, Enterprise Partner API, and Leasing Agent Experience.