Applicant Reports temporarily inaccessble

Incident Report for Snappt

Resolved

This incident has been resolved.
Posted May 29, 2026 - 18:58 UTC

Monitoring

The database has returned to normal function. All services appear to be operating normally. We're continuing to monitor.
Posted May 29, 2026 - 18:10 UTC

Update

We're seeing the impact of this outage spread to the applicant experience as well. Applicants are currently unable to submit. We're still working on a resolution.
Posted May 29, 2026 - 17:47 UTC

Identified

We've identified an issue accessing applicant reports. We're working on a resolution now.
Posted May 29, 2026 - 17:13 UTC
This incident affected: Enterprise Partner API.