Intermittent Service Disruption – Applicant Submissions and Reports

Incident Report for Snappt

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 20:38 UTC

Update

Service has been fully restored for all affected users.
Posted Mar 03, 2026 - 20:38 UTC

Monitoring

The issue impacting the verification inbox and applicant experience has been resolved. We have implemented a fix and are now monitoring the platform to ensure continued stability.

A small number of users may still experience residual issues. If problems persist, please contact our support team so we can assist directly.
Posted Mar 03, 2026 - 19:22 UTC

Investigating

We are currently investigating reports of issues affecting loading reports and submission functionality. The issue does not appear to be impacting all users, but some users may experience errors when attempting to submit or view reports.

Our team is actively working to identify the root cause and restore full reliability as quickly as possible. We will provide updates as we learn more.

We appreciate your patience and apologize for the continued disruption.
Posted Mar 03, 2026 - 17:52 UTC
This incident affected: Applicant Experience and Leasing Agent Experience.